Support:

Other Devices

Search in Community:
Reply
Poster
Posts: 1
Registered: ‎29-03-2017

Problem Connecting to Wifi ("Obtaining IP address.."); Acer Iconia One B3-A30

Hi,

Irish customer here. I have an Acer Iconia One B3-A30 and I am trying to connect it to my home wifi, but when I enter in the password, it just says "Obtaining IP address..", "Saved", "Obtaining IP address..", etc., and never connects.

My modem is the BT Voyager 2110. I have reset the modem a few times. I have also restarted the tablet. Forgotten the network and re-entered the password a few times. I get the same result. My other devices (laptops and another tablet) are working on the wifi.

I looked around online for a solution. I even tried to use a static IP but it didn't connect to the internet. I'm not sure what else to do or where the problem is. I have contacted Acer technical support separately and I'm awaiting their reply.

Any assistance would be greatly appreciated.

Thanks!

Share to Facebook Share to Twitter More...
Message 1 of 3 (1,365 Views)
Moderator
Posts: 2,740
Registered: ‎01-11-2016

Re: Problem Connecting to Wifi ("Obtaining IP address.."); Acer Iconia One B3-A30

Hi there,

As your internet connection appears to be working on other devices, the issue is most likely with your tablet. Unfortunately, as we are unable to offer support on this device, I would recommend that you discuss this matter with the manufacturer directly. I will also keep this post open to the forum as our more technical users may be able to offer you some assistance.

Thanks,

Ashling

Learn all about our new forum, right here .
To send me a private message, simply click here
Please include a link to your thread when sending these over - due to the volume of queries, PMs without a thread link will not be answered.
Share to Facebook Share to Twitter More...
Message 2 of 3 (1,354 Views)
Highlighted
Frequent Poster
Posts: 47
Registered: ‎28-07-2015

Re: Problem Connecting to Wifi ("Obtaining IP address.."); Acer Iconia One B3-A30


Hi Voddy,

While I'm not familiar with either your router or the Acer tablet here is a link to possible solutions to fixing "Obtaining ip address " loops. Seems to be a very common Android problem.


http://tunecomp.net/fix-stuck-obtaining-ip-address-loop-wifi-issue-on-android/

You have tried some of these already but here are my observations on the above solutions from a network novice.

"Solution 4 - Setup up WPA2-PSK on your Router".
Contrary to advice here I would in fact reduce the security type, at least temporarily while testing, to WPA and encryption to TKIP or even to perhaps None  and see what happens. Some routers by default set the highest security settings available, normally that is WPA2-PSK and AES encryption. Many older tablets do not support this level of security. However not sure that any of these settings will make a difference since I think this issue occurs after authentication but worth a try.

Solution 6 - Often overlooked but good advice especially during testing,- Reduce distance between router and device

Solution 10 - Assign a static Ip address to your Android device

Did you use a static ip address outside of the routers DHCP address assigning range. I read somewhere that this was a necessary step for some Acer tablets with this specific wifi connection issues. The example given here is to assign a static ip address of 192.168.0.150 but that may be inappropriate for your router. For instance in the case of my router, R216 mobile broadband, the DHCP range starts at 192.168.0.100 and ends at 192.168.0.200 so I would go for say 192.168.0.250. My Default Gateway is 192.168.0.1. Note the Gateway address might also need changing - use ipconfig in command prompt window to check. DNS's will probably default to Googles 8.8.8.8 and 8.8.4.4.

If you get to "Solution 11 - Resetting your Tablet" and still no joy then here are another few suggestions which have worked for some people. - Delete all saved networks from Tablet and try adding the network manually by entering SSID etc. and match the security or none to what you set on the router. Or perhaps turn on Mac address filtering on router and whitelist the Acer just to see would this somehow wake the router up. Try connecting after your laptop is already connected in case the router is going into some sleep mode and the tablet cannot awaken it but laptop can. Do you have a set of "Homeplugs" lying about that could connect to the router and give out a wifi signal that perhaps the Acer could successfully connect to.

 

That's my 2 cents.

These connection issues are very frustrating so best of luck.

Michael

Share to Facebook Share to Twitter More...
Message 3 of 3 (1,244 Views)