Menu Toggle

Welcome to Vodafone Community

Mobile Network & Coverage

H+ only. My LTE coverage has vanished?

Products and Services FAQs

Products & Services FAQs

Poster

Can you please let me know what's happened. I've always had 4G/LTE at work in Citywest business campus. The past few days I only have H or H+ and it's very slow. Can you find out if the is a problem with my account or with the coverage service in this area?

Thank you. 

View more options
6 REPLIES
Poster

I got through to technical support who said all looked ok. 

They reset my account anyway. I left phone switched off for 5 minutes as instructed and restated. Same issue.

The guy beside me is with Vodafone and has 4G.

My phone setting had not changed - still LTE preferred as it always has been. I've changed nothing.

Address is Waterside, Citywest Business Campus, Dublin 24. 

 

One thing I notice is when I look at phone information, it says SIM/Number unknown. Not sure if that's related. 

View more options
Moderator

Hi there, If you private message (via the link in my signature) over the below info, I can look into this for you? Mobile number: Address: Date of birth: Link to your thread:

 

Thanks

Aoife

View more options
Poster

I don't see a signature or a PM link Aoife?

 

View more options
Moderator

Hi there,

Can you click on my profile and PM me that way?

- Aoife

View more options
Poster

Yes I did try that before my last reply. There is no option to send you a pm. Just your activity feed and last visible time online etc.

 

Smiley Sad

View more options
Moderator

Hmmm, not sure why that's not working but I have sent you a PM, if you could reply to that Smiley Happy

 

- Aoife

View more options
Top Contributors
my-vodafonemenufacebooktwittercommunityclosechevron-downchevron-up