Menu Toggle

Welcome to Vodafone Community

Closure of Vodafone Community 21.06.19 At Vodafone we are constantly reviewing the methods customers can interact with us. Our social channels have evolved and as such we will no longer support the Vodafone Community as of 21.06.19 Our platforms to contact us are • Live Chat by selecting your service type & clicking on the chat pop up • Facebook: • Twitter: We would like to thank everyone that has contributed over the years
Close announcement

Fixed Service Technical Support

DNS Changer on Android

Products and Services FAQs

Products & Services FAQs


Can anyone shed some light on why I would need to use the DNS Changer on my Samsung S7, my daughters J5 and my wifes S6. 
I cant connect to my wifi at home without this app on all devices. 
I have the Vodafone  HG659 and as far as i know it's set to the default settings apart from 1 port forwarding rule for cctv. I have deleted the rule to see if anything changes but no good. 

This doesn't seem to happen with apple phones and a lot of other android devices. 

Would it be a Samsung thing ?, my son has a Samsung Tab 2 10" tablet and it works fine without the app. 

I have also tried changing the DHCP setting on the phones to static and using google's dns but still no good. 

Searched the web and can't seem to fine and answer. 

View more options

Hi there,


If you private message (via the link in my signature) over the below info, I can look into this for you? 


Broadband account number:


Date of birth:




Learn all about our new forum, right here .
To send me a private message, simply click here
Please include a link to your thread when sending these over - due to the volume of queries, PMs without a thread link will not be answered.
View more options
Community Expert

I have the Galaxy S9 currently - The S7 before that - and been to and from friends’ houses on the same product without issue connecting, so my feeling on this is it is not a Sansumg issue per say. 


It is possible the devices have an old config stored if there was an update of some sort to the config. Have you tried to "forget" the wifi entirely, and then reconnect to it?


Basic and a bit of a long shot i know, but something that has saved me time and time again with Virgin Media


View more options
Top Contributors