Menu Toggle

Welcome to Vodafone Community

Android Devices

Rich Communication Bloatware removal

Products and Services FAQs

Products & Services FAQs

Poster

Just updated my Xperia z3 compact to 5.1.1 and i've been getting the rich communication popup every now and then.

I'd like to know how to disable/get rid of it as i don't wish to use it and it's becoming increasingly annoying. I've checked the forums and seen people suggest going to settings -> more and disabling it from there but it's not a visible option for me. I've also seen that the service it's attached to is the messaging service which i can't disable or disable notifications for.

View more options
9 REPLIES
Frequent Poster

To disable Rich Communications do the below

 

Go to Settings

-> Wireless&Networks

->More

-> Rich Communication

 

Just uncheck it and it will be turned off. Rich communication is sort of like iMessage in a way because it allows you to send free SMS to friends who also have it.. It is a handy feature.. May be worth setting it up.

View more options
Poster

Like i've stated in my original post there is no option under wireless & networks -> More -> Rich communication to disable it. The only options available to me under More are:

Airplane mode

Default SMS app

NFC

Android Beam

Tethering & Portable Hotspot

VPN

Mobile Networks

Internet Settings

View more options
Frequent Poster

Hi

 

sorry about the delay I was waiting to check a friends phone who is using sony,

 

Ok go to

 

-> Messages

-> Settings

and then it is listed under chat services so just simply untick it Smiley Very Happy

View more options
Community Manager
Community Manager

Hi there,
Did the suggestion above resolve the issue for you?

Thanks,

Learn all about our new forum, right here .
To send me a private message, simply click here
Please include a link to your thread when sending these over - due to the volume of queries, PMs without a thread link will not be answered.
View more options
Poster
I owe a Z3 also and none of these worked for me. The options mentioned don't appear in my Messages aplicación. Is there a Service I could Block to get rid of this annoying scam? It showed up three times while I was writing this Smiley Sad
View more options
Moderator

Hi there,

 

Apologies for the delay in coming back to you. We will escalate this to the relevant team.

 

- Aoife

View more options
Moderator

Hi there,

 

The relevant team have asked for more info on this- could you send a private message with your number, address & DOB, a link to this thread and screenshots of the error received, we'll take a look. 

 

- Aoife

View more options
Poster

On Huawei we found the rich communication enable/disable button under:

 

* Settings

* Wifi & Network

* Call Settings 

* Call+

 

Blergh.

View more options
Poster

On Huawei we found the rich communication enable/disable button here:

 

Goto Settings

-> Wireless & Networks

-> Call Settings

-> Call+

 

Yuk, vodafone.

View more options
Top Contributors
my-vodafonemenufacebooktwittercommunityclosechevron-downchevron-up